Problem:

You may be unable to move the mouse pointer through Remote Control if the customer is using a Macintosh device with macOS Mojave 10.14.x.


Cause:

Apple changed a security mechanism in macOS, starting with the Mojave version. The change requires the customer to give explicit approval for an app (in this case, Remote Control) to receive a certain permission (in this case, mouse control). The permission must be granted by a user with admin rights and cannot be granted remotely; the customer must grant access locally before you can establish a remote session.


Work-Around:

You can work around this issue by walking the customer through the steps to grant you permission to control the mouse. Once the customer has granted permission, you do not need to repeat these steps for that customer.

  1. The first time you attempt to control the mouse under these conditions, the customer sees this Accessibility Access (Events) window appear:
  2. Instruct the customer to click the Open System Preferences button, and then the customer sees this window appear:
  3. Instruct the customer to select the check box next to sh.

Looking Ahead:

Because Apple requires that the permissions be granted in this way, we cannot eliminate the need for this procedure. However, in the near future, we'll be updating the name of the app from sh to something more recognizable and reassuring to the customer.